Images and PDFs are not correctly shown in the journal export or pdf export


I really like your app and its working really well for me except for the function to view the lab entries in a journal format. I use a lot of images in my work which I usually copy and paste from other programs, or take photos using my phone. These display fine in the individual entries. However when I view the journal many of them are missing. The file is visible but the image is not displayed. I can’t seem to find any pattern to this though, its not all images. Is anyone else having this problem or might know whats causing this?


Hi Will,

I am very sorry about the issue. Could you maybe send an example of experiment where the issue happens? You can use the menu File > Export as Archive, to send us. You can email to keep the communication private.

Do you have the same issue when using File > Print?

Thanks for your patience and the feedback!


Hi Charles,

Thanks for getting back.

The problem seems really random. Images that were not displaying before the weekend now are, but there are still lots that aren’t. All the images in the April journal now display fine, but many from March do not.

I’ve done a few tests. If I export an entry on its own as an achieve as you suggested, the pdf it makes shows everything fine. The same entry in the month journal has images missing. Trying to print the month journal also misses the images for this entry.

Interestingly I just tried forcing the month journals to recreate the pdf’s by changing to large images, and now everything is displaying as it should. However I tried this on Friday without luck, not sure why it worked this time. Seems to be an intermittent problem with how the pdf’s for the month journals are generated on my mac. Does findings use any other software / library in the pdf generation I should check?


Thanks a lot for the feedback. I am not sure what went wrong with the creation of the images for the journal. The journal PDF is created just once and saved to disk automatically, and will stay as they were created unless the content changes. I suspect whatever was wrong with image creation led to those cached PDFs to have no image. By changing the setting for images, you triggered a new creation of the journal, which may have taken a while to get through and you are now seeing newly created PDFs with the right content.

Again, sorry for the confusion, and the wasted time. I’ll keep an eye out for any bug with the PDF creation.

Thanks for your patience,


Hi Charles,

When I add new content some of the images don’t appear to load correctly in the new journal entry. However refreshing the journal by changing to no attachments, and then back to large attachments, seems to load everything fine. Hopefully we can figure out whatever is causing this at some point, but I’m fine with this work around otherwise.
Great app though!


1 Like

I have gotten the exact same problem. This used to work well (at least until 2018), but I hadn’t done it in quite a while and now I have this huge problem that around half of my images do not show up. And as the other user said it seems to be pretty random which type of files (I have .png / .pdf / .jpeg and .tiff files) do not show up in the exported pdf… For me it did not help to set it to no images and then back to large previews. Will could you tell me if you closed and restarted the program in between or did anything else besides just changing the settings back and forth?

It’s mostly in files that have a lot of attachments that it goes wrong. Then if I export it again, it can be other files that are missing!