Changing the style of calendar ( year ) with AD

calendar
feature

#1

Hello,

I use Findings in Japanese.
The language setting of mac is: 1st. Japanese / 2nd. English

When I add the “Day”, the date information appears in English with era name like “January 20, 30 Heisei”.

Is it possible to change like “January 20, 2018” (using AD)?

it would be more better to be able to select the date style and language.

Thanks.


#2

Thanks for the feedback. Indeed, I tried to make Findings adapt to the user language and preferences, in particular around dates, but I can also see how one would prefer to stick to the Gregorian calendar for the years. I have added your idea of a preference to my list. At this stage, I can’t promise when that will happen, but I sure hope to get to it in the future, and will let you know here.

In the meantime, you can in fact set Findings to run in English, independently of your system preferences, with these steps:

  1. Quit Findings

  2. Open Terminal.app (found in /Applications/Utilities)

  3. At the prompt, type the following all in one line (you can copy paste) and press return

    defaults write com.findings.Findings AppleLanguages '("en-US")'
    
  4. Restart Findings, it should now be in English

If you ever need to reset that setting in the Terminal, type the following:

defaults delete com.findings.Findings

Let me know if that solves the issue for you.

Charles


#3

Hi,
Thank you for the tips!

I tried it and appearance is changed.

FYI:

  1. at first, the code was not worked and following error was appeared.

syntax error near unexpected token `)’

the following code was work well.

defaults write com.findings.Findings AppleLanguages "(en-US)”

  1. it is not in AD (like Jan. 28, 2018) but totally in Japanese
    (like 平成30年1月28日).

This is correct order in Japanese and no problem, but it is a little strange (because I set up the language as English, not Japanese).


#4

Sorry about the issue with the wrong characters. The straight quotes have been changed into curly quotes by the forum editor, and are not legal characters.

I have corrected my response above. Just to be sure, can you try again with the following:

defaults write com.findings.Findings AppleLanguages '("en-US")'