Sluggish response

What I did:Sometimes when entering text, response is very slow, I might type 3-5 characters before one shows up on the screen, and if I keep typing without pausing, the input cursor will jump to the start to the paragraph.

What happened:

What I expected:

Things that might be helpful to know (Findings version, OS and model, etc): Findings 2.0.7, MacOS 10.13.5, iMac (Retina 5K, 27-inch, 2017). I do have a lot (>100) experiments in the ongoing category, if that makes a difference.

I am very sorry about the issue. I am not entirely sure what could be causing this. Is maybe the entry itself very long? When the issue happens, does it help if you switch to another entry and then back? Or else does it help if you quit the app and open it again?

To help diagnose the CPU issue, it would be very useful to get an activity sample from Findings when it happens. For this, you’ll need to open the application called ‘Activity Monitor’, which you will find in /Applications/Utilities. In the search box, type ‘Findings’ and you should have just one row showing the activity of the app. Select the row, click on the cog wheel icon in the toolbar, and select the ‘Sample process’ item in the popup menu. The sampling will begin immediately, and you will then need to quickly go back to Findings and do whatever is needed to trigger the intense CPU usage. The sampling takes about 5-10 seconds. You can choose to ‘Save’ the sample and then you can send it to me in reply to this email. It would be probably useful to have 2 or 3 of those samples to be sure.

Thanks for your patience and help diagnosing the issue!


Hi Charles,

I am also having this issue. When entering text, the response will suddenly become very slow (no response for up to 10 secs) and the input cursor will often jump to the start of the paragraph. During this time activity monitor will claim that Findings is using as much as 50% of CPU.

I have saved three versions of the samplings. Is there an e-mail address I should send them to?

Thanks for the samplings! You can email

In the meantime, here are instructions to “clean” the derived data that Findings uses for various purposes. This may help restore performance.

First, you will need to get to your Findings support folder on disk:

  • In Findings, choose the menu Findings > Preferences
  • In the preferences, choose the ‘Library’ tab
  • Press the button ‘Reveal in Finder’ in the box ‘Derived Data’
  • This will select a folder called ‘Findings’ in the Finder, which contains 3 subfolders
  • Quit Findings
  • Back in Finder, rename the subfolder ‘DerivedInfoV2’ to be instead called ‘DerivedInfoV2-OLD’ (do not change anything else in the ‘Findings’ folder)
  • Start Findings again

Initially, the app will seem empty. Gradually, all your experiments and protocols will appear. It will be processor intensive, as Findings is rebuilding a cache of all your documents, including the search index and a database for the user interface.

If all is good, you can move the ‘DerivedInfov2-OLD’ folder to the trash. Let me know how it goes!

Hi Charles,

I tried the fix you suggested. There was an improvement in the response time for Findings, but within a week the problem has re-surfaced.

@sdswain and @buffaloplease I am really sorry the problem keeps resurfacing. I can’t seem to find an obvious culprit in the CPU samples so far. I’ll keep investigating…

Hi Charles, I’m sad to say I have the same lag problem every time I start typing or switch between experiments, unfortunately it is bad enough that Findings is not usable for me. I have also tried deriving data again but this does not fix the problem.

Have you been able to find a solution to this problem? Is there a way I can temporarily remove some of my larger projects from Findings to see if it can handle smaller projects?