Findings 2.0.3 Beta - Pro account turned into basic - FIXED IN BUILD 5420

bugreport

#1

What I did: Update the lastest Findings

What happened:My account just suddenly become basic with limited number of experiments

What I expected: Have my pro account back

Things that might be helpful to know (Findings version, OS and model, etc): Version 2.0.3, OS Sierra 10.12.6. I also cannot find upgrade button to check the status of my account.


#2

Sorry about this registration issue. I have now identified an issue with the beta version 2.0.3 that’s been confirmed by two other users. I will be working on an update to the beta version to fix the issue.

If you have a few minutes, could you please send me the Info.plist from your library? Here is how to get to the configuration file ‘Info.plist’ for your Findings installation on your Mac:

  • In Findings, choose the menu Findings > Preferences
  • In the preferences, choose the ‘Library’ tab
  • Press the arrow button in the ‘Derived Data’ box
  • This will select a folder called ‘Findings’ in the Finder
  • In this folder, you will see a subfolder called ‘PersistentInfoV2’
  • That folder contains the file ‘Info.plist’

This file should help me understand the configuration that leads to the issue. Please DO NOT SHARE IT here, this is a public discussion. Instead, send it to our support private email feedback@findingsapp.com. Thanks a lot for your help!

To fix the issue, you can download version 2.0.2 from our website: http://downloads.findingsapp.com/v2
By downloading the app from the website, you will revert to version 2.0.2, which does not have that bug. If you get an update notification for the beta build 5406, please skip it for now. I will let you know when a new beta fixes the issue.

Let me know if that helps,

Charles


#4

Hi Charles,

I am experiencing an identical issue with add experiments now disabled as I have more than 20.

Happy to send you files etc off forum if useful.

Colin


#5

Rolling back to 2.0.2 fixes things for the time being.

Thanks,

Colin


#6

Hi Colin,

Thanks for the report! If you have a couple of minutes, could you follow the instructions to send me the ‘Info.plist’ file from your Findings library? That would be useful to diagnose and understand the issue and fix it for the next beta.

See instructions here: Findings 2.0.3 Beta - My pro account suddenly turned into basic

Thanks a lot!

Charles


#7

I have just sent you the file in the email!

Thanks
Jirawas


#8

I met the same issue. Any solution yet?

Thanks,

Weiyan


#9

I have released a new beta for version 2.0.3, which fixes the issue. You can simply use the menu Findings > Check for Updates… The new build number is 5420 (or higher for subsequent releases). Let me know how it goes!

Thanks to all of you for your patience and for reporting the issue so quickly!


#10

Hi Charles,

This issue seems to either have resurfaced or remain unresolved in Build 5423.5286e49c.

Thanks,

Colin


#11

Hi Colin,

This issue seems to either have resurfaced or remain unresolved in Build 5423.5286e49c.

That’s weird. I can’t reproduce the issue as I could in the initial build 5406. Can you check the version number using the menu Findings > About Findings, and then also check the menu Help to see if you see the option to ‘Upgrade to Pro’ or ‘Enter License Code’? Thanks for your help!

Charles


#12

Hi Charles

This seems to be an issue with my system and something conflicting from the previous install. I cleared my task bar and replaced with a fresh short cut and all appears well in version 5423.5286e49c.

Thanks,

Colin


#13

Something odd here on my system, this may be a conflict with something that has not updated correctly. I can open findings from my applications folder, same version as before 5423.5286e49c and all is well. However if I open from my task bar I have the issues described previously. I will delete the task bar icon and see if this clears the conflict.

Colin: it looks like you have indeed 2 versions of Findings on your hard drive. The build 5423 is the one you open from the Finder. The one in the Dock is in another location, which you can determine by control-click on the icon, then go in Options > Show in Finder.

If you can, it’s best to install the app in the Applications folder on your hard drive. Updating from the app will keep it in the same location. What may have happened is that you downloaded the app again from our website, and that other instance of the app is in your downloads folder maybe.

Many thanks for your report, and for your quick answer. I’d rather have a false alarm than no report, and then it’s good to know the issue is in fact gone for you!

Charles


#14

Hi Charles,

The behavior here is odd, I have been using findings all day without issue but it has just popped up the update to pro message as it appears to think I am in my 20 day trial period.

Version is 5423.5286e49c, I cant see any other versions on my hard drive but I will take a closer look incase something is lurking.

Thanks,

Colin


#15

Hi Charles,

I found another version (older) in my downloads folder which I have removed. I will let you know if that resolves the issue.

Colin